SYSTEM NOTIFICATION: PHONE INTERRUPTION

Incident Report for Internet Testing Systems

Update

Our phone systems are now operating normally. We apologize for any inconvenience this may have caused.
Posted Apr 22, 2026 - 17:27 EDT

Update

While we continue to investigate the connectivity issues with our phone provider, please contact our support team via phone by dialing 443-317-9377
Posted Apr 22, 2026 - 13:09 EDT

Investigating

We are currently experiencing connectivity issues with our phone provider. If you are unable to contact us via phone, please contact ITS Support at support@testsys.com
Posted Apr 22, 2026 - 12:50 EDT