Testing Event (113) (10/22/2025-10/31/2025)

Incident Report for Internet Testing Systems

Update

We have identified and addressed an issue impacting a small number of Mac users that prevented them from being able to test. This issue has been resolved. Those affected can now proceed with their exam. We apologize for any inconvenience this has caused.
Posted Oct 23, 2025 - 08:47 EDT

Update

We are aware of an issue currently effecting a small number of Mac users preventing them from being able to test. If you are using a Mac and having trouble testing, please download an updated version of the Safari browser. The latest version of Mac products can be downloaded from https://www.apple.com/support/mac/
Posted Oct 22, 2025 - 12:05 EDT

Update

We are aware of an issue currently effecting a small number of Mac users preventing them from being able to test. We are actively investigating this issue and will provide an update as soon as one becomes available
Posted Oct 22, 2025 - 11:19 EDT

Update

We are aware of an issue currently effecting a small number of Mac users preventing them from being able to test. We are actively investigating this issue and will provide an update as soon as one becomes available
Posted Oct 22, 2025 - 10:38 EDT

Update

We are aware of an issue that may be preventing some test takers from starting their test. We are actively investigating the issue and will provide an update as one becomes available.
Posted Oct 22, 2025 - 10:15 EDT

Monitoring

This is a placeholder for the testing event that begins Wednesday October 22, 2025 and runs through Friday October 31, 2025.

Proctors are encouraged to subscribe to this blog to receive exam-day updates via text or email messages.
Posted Jun 20, 2025 - 10:42 EDT