Our phone systems are now operating normally. We apologize for any inconvenience this may have caused.
Posted Apr 22, 2026 - 17:26 EDT
Update
We are currenty experiencing connectivity issues with our phone provider. If you are in need of technical assistance with your exam, please dial 443-317-9377
Posted Apr 22, 2026 - 13:25 EDT
Update
Our phone system is now fully operational. We apologize for any inconvenience this may have caused.
Posted Apr 20, 2026 - 11:59 EDT
Update
The system that allows our support team to answer phone calls is currently experiencing technical issues. Please contact the ITS Support Team through email at support@testsys.com
Posted Apr 20, 2026 - 11:15 EDT
Monitoring
This is a placeholder for the testing event that begins Sunday April 19, 2026 and runs through Saturday May 2, 2026.
Proctors are encouraged to subscribe to this blog to receive exam-day updates via email. Text message alerts are only sent for final event resolution.