Testing Event (3/7/2026) (278)

Incident Report for Internet Testing Systems

Update

This issue is now resolved we apologize for any inconvenience this has caused. Candidates may resume testing by closing and relaunching the secure testing browser.
Posted Mar 07, 2026 - 11:39 EST

Update

We are currently investigating an issue impacting test delivery. Candidates may receive communication errors while starting or navigating through their test. We recommend, if possible, switching the candidate to a different device to resume testing while we investigate this issue further
Posted Mar 07, 2026 - 10:13 EST

Monitoring

This is a placeholder for the testing event that occurs Saturday, March 7th, 2026.

Proctors are encouraged to subscribe to this blog to receive exam-day updates via email. Text message alerts are only sent for final event resolution.
Posted Dec 01, 2025 - 14:02 EST